[ILUG-BOM] unable to make menuconfig

Rajen Parekh rajen@[EMAIL-PROTECTED]
Fri Jun 29 11:57:45 IST 2001


On Thu, 28 Jun 2001, noel seq wrote:

> 
> Hi Luggers,
> 
> It all started after I started to upgrade my kernel from 2.2 to 2.4.2 as 
> philip suggested, i untarred the 2.4.1 kernel but was unable to add the 
> patch. While applying the 2.4.2 patch, it gave me an error :
> 
> patch unexpectedly ends in middle of line
> unexpected end of line in patch.

There could be 2 things. Either your patch file has not downloaded
completely or else you are not able to patch the patch file. To check out
whether you could download the complete file, check the file size of the
downloaded file with the one from where you downloaded. Alternatively, you
can check file integrity with 

$ bunzip2 -t <file name>

If the file is proper then I suggest you use the patch scripts that is
available with the kernel source. Copy your patch file in the top level
kernel source directory (though I don't think it is necessary). Change
to that directory and run;

$ ./scripts/patch-kernel  <path to patch file>

The path in above case would be your current directory so you can just
give a '.' and thats it. It will find the patch file (in any format,
whether bz2 or gzip) and apply it. I had proble using patch command and
found running this scrip more easy. No errors. 


[Snip]

> Then i downloaded gcc-2.96-54 which gave me an rpm error saying major 
> numbers <=3 are supported.
> So i am upgrading rpm to 4.0.1-0.6x and it is giving me an error
> failed dependencies libdb-3.1.so is meeded.
> 
> Am i going in circles. Is there a simpler way. Please advise.


I am using rpm-3.0.5-7 and I have no problem whatsoever with it. It is
compatible with the new versions of rpm. AND it gets installed with the
old rpm that you would be having.


Regards,

Rajen.




More information about the Linuxers mailing list