[ILUG-BOM] CD ROm detection problem in RH 7.2

Anand Iyer akiyer@[EMAIL-PROTECTED]
Fri Jan 25 11:24:16 IST 2002


Hi Kunal and others trying to help,
I removed the append="hdc=ide-scsi"
from lilo.conf.
ran lilo.

booted the machine.
And inserted a PCQ CD inside the drive and tried mount when it did not automount.
Then removed the fstab line for CDROM.

Rebooted the machine.
Still the same results.
I am not worried about CD recording at this moment.
Machine history:
Loaded PCQ 7.1 in July and running smoothly since then.
CDRecord and ordinary CD usage with the lilo line "append...."
was there.

Upgraded recently to RH 7.2 using Seascope CD's.

The CD's are with me and the kernel being used is 2.4.7-10 .

Initially I had a installation problem and I got another set of CD's with me now.
The install has worked smoothly so far.
But the CD ROM is not being read.

I went to hardware browser in Gnome after logging in as root
Window shows on left
CDROM Devices

Right Hand top side shows
SAMSUND CD-R/RW DRIVE SW-208F

Bottom right hand side window shows
manufacturer: unknown
driver: ignore
Device: /dev/hdc

So I am a bit confused.
I believe his means that the CDROM is detected in /dev/hdc
and ths SAMSUNG ...
that is seen means that the CDROM drive is being properly detected by some software component
however the bottom part of the window is worrying and shows that the CDROm detection has some problems.
is this Kernel Related?

Please note that the same system has caldera loaded in another partition with 2.4.2 and the system is running smoothly.

Anand


Message: 5
From: "Kunal Gangakhedkar" <kgangakhedkar at yahoo.com> <mailto:kgangakhedkar at yahoo.com>
To: <linuxers at mm.ilug-bom.org.in> <mailto:linuxers at mm.ilug-bom.org.in>
Subject: Re: [ILUG-BOM] CD ROM problems Kernel 2.4.7-10
Date: Tue, 22 Jan 2002 21:10:22 +0530
Reply-To: linuxers at mm.ilug-bom.org.in <mailto:linuxers at mm.ilug-bom.org.in>

Well, as I can see from the scenario, your CDRW is getting detected as
a SCSI drive.
In fact, it is an IDE drive - am I right??

To get around with the problem, just remove the "append=...." line
from lilo.conf 'coz you don't need it.
Then update lilo using /sbin/lilo.
The next time you boot into linux your CDRW should be detected as an
ordinary IDE CDROM.
But then, you won't be able to write CDs through linux, 'coz all the
CD- Writing softwares in linux (including cdrecord and Xcdroast)
need your drive to be SCSI.

Now, to make your IDE CDRW (now detected as an IDE CDROM) work for
writing CDs, what you can use is an emulation driver - ide-scsi.
This is precisely what you've been seeing in your lilo.conf.
This is a modular driver which can be used using modprobe or insmod.
The advantage is - install when you want, uninstall after using it.
I guess, you know how to uninstall / remove modules.

When you add this driver, just check out the working of the driver
using
#cdrecord -scanbus

If you get the output saying the HOST/DEVICE/LUN ids, then you can be
pretty sure that the driver will work for you.
The only problem I faced was that the normal IDE-CD emulation driver
used to interfere with it.
So, to be on a safer side, make sure that you remove ide-cd before
inserting ide-scsi.
The ide-scsi driver is available online or can be found at PCQ's
wesite (in fact, it comes built into PCQ Linux Distro).

After you're done with the CDRW for writing, remove the ide-scsi
driver using
#rmmod sg
#rmmod ide-scsi

These are dependant modules.

Then insert the usual ide-cd driver using
#modprobe ide-cd

And you'll be back with your CDRW as IDE CDROM.

For more information, pls. refer to CD-Writing HOWTO

Kunal
------------------

The choice is yours, don't be late
Take a rest as a friend as an old memory

Nirvana - Come As You Are




----- Original Message -----
From: kishor bhagwat <aaaaarrrgghhh at yahoo.com> <mailto:aaaaarrrgghhh at yahoo.com>
To: <linuxers at mm.ilug-bom.org.in> <mailto:linuxers at mm.ilug-bom.org.in>
Sent: Tuesday, January 22, 2002 10:46 AM
Subject: Re: [ILUG-BOM] CD ROM problems Kernel 2.4.7-10



>>
>> --- Anand Iyer <akiyer at vsnl.com> <mailto:akiyer at vsnl.com> wrote:
>
>>> > My CDROm drive Samsung CD writer  RW 8.4.32 is recognised
>>> > by the kernel,
>>> > but when i try to mount the CDROm, I get a message
>>> > /dev/cdrom improper device or device does not exist.
>>> > I have the following line in lilo.conf
>>> > append="hdc=ide-scsi"
>>> > This used to work and still works on Caldera with kernel
>>> > 2.4.2 (PCQuest
>>> > CD's)loaded in another partition.
>>
>>
>> the append line in your lilo.conf means that scsi emulation
>> is used for your drive(cd burning programs require it).
>> try mounting /dev/scd0 as your cdrom drive..
>>
>> regards,
>> kishor
>>
>>
>>
>>
>>
>






More information about the Linuxers mailing list