[ILUG-BOM] Motorola SM56 modem not detected and depmod error

Vinord Anand vinord.anand@[EMAIL-PROTECTED]
Tue Dec 24 16:37:46 IST 2002


I am trying to set up modem to access Internet.
I have dual boot system with Win98 and Reh Het 7.3 (2.4.18-3)
modem works OK when connecting to Internet using
Win98 dial up networking tools.

This is my modem details
Its SM56 PCI I Motorola Speakephone modem.

[root at localhost scanModem]# lspci |grep SM56 PCI
00:09.0 Communication controller: Analog Devices SM56 PCI modem
 Subsystem: Analog Devices SM56 PCI modem
 Flags: bus master, medium devsel, latency 64, IRQ 5
 Memory at e7000000 (32-bit, prefetchable) [size=256]
 Capabilities: [dc] Power Management version 2

[root at localhost floppy]# cat /proc/pci|grep SM56 PCI
  Bus  0, device   9, function  0:
    Communication controller: PCI device 11d4:1805 (Analog Devices) 
(rev 0).      IRQ 5.
      Master Capable.  Latency=64.  Min Gnt=1.Max Lat=255.
      Prefetchable 32 bit memory at 0xe7000000 [0xe70000ff].

I have a problem in that wvdial can't detect my modem.
When use Red Hat 7.3 PPP dialer (Internet Configuration Wizard)
Modem probing says no modem was found on your system

[root at localhost scanModem]# wvdialconf /etc/wvdial1.conf
Scanning your serial ports for a modem.

ttyS0<*1>: ATQ0 V1 E1 -- ATQ0 V1 E1 -- ATQ0 V1 E1 -- nothing.
ttyS1<*1>: ATQ0 V1 E1 -- ATQ0 V1 E1 -- ATQ0 V1 E1 -- nothing.
Port Scan<*1>: S2   S3   S4   S5   S6   S7   S8   S9

Sorry, no modem was detected!  Is it in use by another program?
Did you configure it properly with setserial?

I already have driver for my Motorola PCI SM56 Speakerphone
(data/fax/voice) modem.I got driver files for Windows from same 

I am using driver package

[root at localhost root]# rpm -Uvh  SM56_5.1_I386.rpm
[root at localhost root]# sm56setup 679
Motorola SM56 SoftModem Setup for Linux

Building driver...
`/usr/local/sm56/sm56.o' ->
Creating device /dev/sm56...
Pointing /dev/modem to /dev/sm56...
Adding SM56 to /etc/modules.conf...

SM56 setup complete

[root at localhost root]# ls -ltr /dev/* |grep sm56
crw-r--r--    1 root     root      24,   0 Dec 19 16:52 /dev/sm56
lrwxrwxrwx    1 root     root            9 Dec 19 16:52 /dev/modem ->

[root at localhost root]# modprobe sm56
Warning: loading /lib/modules/2.4.18-3/kernel/drivers/char/sm56.o
will taint the kernel: no license
Segmentation fault

I also get some depmod errors

[root at localhost scanModem]# cat /var/log/messages |grep sm56
Dec 21 19:06:20 localhost depmod:
depmod: *** Unresolved symbols in
Dec 21 19:06:20 localhost rc.sysinit: 
Finding module dependencies:failed
Dec 21 19:07:11 localhost modprobe: 
modprobe: Can't locate module char-major-81

Today I tried new driver package from
http://linmodems.technion.ac.il/Motorola.html but also gave some
unresolved symbols

[root at localhost root]# rpm -Uvh sm56-85.1-10.i386.rpm
[root at localhost root]# sm56setup 679

    Motorola SM56 SoftModem Setup for Linux

Building driver...
`/usr/local/sm56/sm56.o' ->
Creating device /dev/sm56...
Pointing /dev/modem to /dev/sm56...
Adding SM56 to /etc/modules.conf...
depmod: *** Unresolved symbols in
depmod: *** Unresolved symbols in

SM56 setup complete.

I tried using fixscript from http://www.heby.de/ltmodem (don't
know if I need it since modem is not LT) but coudn't get it to run.

Do I also need an updated serial driver!!

This is what dmesg shows.............
Serial driver version 5.05c (2001-07-08) with MANY_PORTS MULTIPORT
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A

no trace of ppp support or pppd daemon on my system.
I thought ppp support was provided by default by RH7.3 kernel
However after have tried to manually load sm56 
[root at localhost root]# modprobe sm56

$lsmod and $cat /proc/modules always have
sm56                 1557324 (initializing)

Never stops initializing!

My /etc/wvdial.conf looks like this 

[Dialer Defaults] 
Modem = /dev/ttyS1 
Baud = 57600 
SetVolume = 4 
Dial Command = ATDT 
Init1 = ATZ 
Init2 = AT&F&D2&C1V1S0=0E0 
Init3 = ATS7=60\T0M1\N7%C1\Q3*LS1X4 
Phone = 144000 
Password = hidden 
Username = hidden 
FlowControl = XONXOFF 

[Dialer connect] 
Phone = 144000 
Password = hidden 
Username = hidden 
Stupid Mode = 0 

I tried other ports  as well...... /dev/sm56 as one artical on web 
by Marvin Stodolsky suggests amd /dev/modem.Windows detected modem 
on COMM3 which would be /dev/ttyS2 in Linux but I haven't tried 
this yet. But there is this article which says it should't matter
which internal port is being used by Windows for modem. 

I have been searching using google for almost 2 weeks, 
had subscribed to close to dozen mailing lists, 
sent close to dozen mails but still no progress. 
I have researched problem well (ref. e-mail
addreses I know of people who had posted to some mailing lists 
regarding this problem) .

I haven't considered option to throw away my modem yet!
Any help would be very much appreciated.

Vinord Anand

More information about the Linuxers mailing list