[ILUG-BOM] Older glibc

Rajesh Deo rajeshdeo@[EMAIL-PROTECTED]
Mon Mar 3 19:13:47 IST 2003


On Mon, 3 Mar 2003, Manish Jethani wrote:

> Hi!
> 
> I'm getting a nasty jvm hang on redhat 2.1as.  Just trying to 
> figure out where the problem could be.  I wanted to know what's 
> the quick-n-dirty way to make the jvm use an older version of 
> glibc.  I have glibc-2.2.4-26 and would like to use some older 
> version like 2.1.3 etc.  Is it sufficient to just place the .so 
> somewhere and include it in the LD_LIBRARY_PATH?

It may work if LD_LIBRARY_PATH is defined from within startup scripts 
of JVM. Otherwise you can put compat glibc in standard places like  
/usr/i386-glibc-21-linux and include that in /etc/ld.so.conf, I guess 
compat-libs rpm packages do all that. Best would be to use ldd to first 
see what libraries it needs.

> -mj

-- 
Time is nature's way of making sure that everything doesn't happen at once.
Space is nature's way of making sure that everything doesn't happen to you.





More information about the Linuxers mailing list