Booting Xandros with GRUB boot loader (WAS Re: [ILUG-BOM]Xandros3.0 and Toshiba Tecra 8100: does not read bootable CD#1)

Rony Bill ronbillypop@[EMAIL-PROTECTED]
Mon Jun 13 16:54:37 IST 2005


sherlock at vsnl.com wrote:

>># This entry automatically added by the Debian installer for an
>>existing # linux installation on /dev/hda12.
>>title		Mandrake Linux 10.1 (on /dev/hda12)
>>root		(hd0,11)
>>kernel		/boot/vmlinuz root=/dev/hda12 ro acpi=ht resume=/dev/hda10
>>initrd		/boot/initrd.img
>>savedefault
>>boot
>>
>>
>># This entry was added manually after loading Xandros 3 on
>>/dev/hda11 title	Xandros 3 (on /dev/hda11)
>>kernel (hd0,10)/boot/vmlinuz-2.6.9-x1
>>initrd (hd0,10)/boot/initrd-2.6.9-x1.gz
>>savedefault
> 
> 
> kernel (hd0,10/boot/vmlinuz-2.6.9-x1 root=/dev/hda11 
> you did not tell the kernel it's root partition. The error would have been 
> kernel panic unable to mount root filesystem blah blah
> 

The script posted was the last abandoned one. Different options were 
tried out but no result. In order to be sure, I tried out the 
root=/dev/hda11 entry again but it stops at kernel panic and gives the 
same 'root=' related error. Do you have any old working scripts for 
pointing grub to lilo?

Can I get into grub prompt in one booted distro and test the grub of 
another distro? Will the testing kernel clash with the one already up in 
the RAM?

Regards,

Rony.

		
___________________________________________________________ 
How much free photo storage do you get? Store your holiday 
snaps for FREE with Yahoo! Photos http://uk.photos.yahoo.com





More information about the Linuxers mailing list